Juniper SRX Router LACP Port Channel

Merhaba arkadaşlar bu makalemde Juniper SRX router cihazları ile Cisco arası port channel nasıl yapılır anlatacağım

Juniper Tarafı Configleri;

ilk önce aşağıdaki komut ile kaç adet interface’i LACP olarak çalıştırmamız gerektiğini belirtiyoruz benim data center yapım büyük olduğu için şuan 50 adet LACP çalıştırıyorum,

set chassis aggregated-devices ethernet device-count 50

aşağıdaki komutlar ise bir port-channel interface’i oluşturmak ( ae0 ) adında isterseniz siz ( ae1,ae10,ae2 vs.) olarakta birden fazla oluşturabilirsiniz

set interfaces ae0 description MPLS-LEAF-1 
set interfaces ae0 aggregated-ether-options lacp active 
set interfaces ae0 aggregated-ether-options lacp periodic fast

VLAN TRUNK’lı olarak oluşturacaksanız, ( aşağıdaki 1 satırlık confiği eklemeniz gerekiyor )

set interfaces ae0 vlan-tagging

ve son olarak aşağıda fiziksel interfacelerin altına girip ( LACP confiğini yapacağız )

set interfaces xe-1/0/1 description LEAF-1_PORT 
set interfaces xe-1/0/1 gigether-options 802.3ad ae0
set interfaces xe-15/2/1 description LEAF-1_PORT-2 
set interfaces xe-15/2/2 gigether-options 802.3ad ae0

Yukarıda ( ae0 ) interface olarak oluşturulmuş ise fiziksel interface’leri de eşleştirmeniz gerekiyor  örneğin: 4 adet fiziksel portunuz var 2 port aci spine node 1 e gidecekse ae0 eşleştireceksiniz diğer 2 port ise vpc deki diğer spine’a gidecekse ae1 olan ile eşleştireceksiniz.

 

aşağıdaki config ise classic cisco port-channel confiği

Cisco Tarafı;

interface Port-channel6
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast network

CORE-AGGREGATE#sh run int Te8/1 
Building configuration... 
interface TenGigabitEthernet8/1
 description MPLS-SPINE
 switchport
 switchport mode trunk
 spanning-tree portfast network
 channel-protocol lacp
 channel-group 6 mode active
end

CORE-AGGREGATE#sh run int Te8/5
Building configuration...

Current configuration : 182 bytes
!
interface TenGigabitEthernet8/5
 description MPLS-SPINE2
 switchport
 switchport mode trunk
 spanning-tree portfast network
 channel-protocol lacp
 channel-group 6 mode active
end

Leave a Reply

Your email address will not be published. Required fields are marked *